Jamf Pro 10.4.1 is now available on TramsCloud

Published on May 11, 2018 in Jamf Pro, TramsCloud

This is a recommended update for all customers who need to comply with the EU General Data Protection Regulation (GDPR) and we recommend upgrading before the 25th of May. If you would like your instance to be upgraded please email support@tramscloud.co.uk to schedule the upgrade.

For information on GDPR ‘right to be forgotten’ and how to comply with these requests using Jamf Pro 10.4.1 see https://www.jamf.com/jamf-nation/articles/520/complying-with-gdpr-requests-in-jamf-pro

For information on personal data stored in Jamf Pro and when it is removed see https://www.jamf.com/jamf-nation/articles/521/gdpr-compliance-reference-for-jamf-pro

For more information on this release please see http://docs.jamf.com/10.4.1/jamf-pro/release-notes/What’s_New_in_This_Release.html

Go Back